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Font Book error

Written by Technical Support

Updated at October 6th, 2023

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Table of Contents

Problem Cause Solution

Problem

You're using the prototype Theme Fonts feature on macOS and you see this message:

Cause

In order for BrightSlide to be able to populate the list of fonts in the window below, it's needs to request the macOS Font Book app to provide the list of installed fonts.

This is called Automation and to do that, the user has to grant PowerPoint with permission to talk to the Font Book app. Even if this permission has been granted, the automation still doesn't work:

It appears that a change was made to macOS around 2022 which removed this automation capability.

Solution

A new method to get the fonts will be integrated from BrightSlide 1.0.6.7 and until that is released, you can update 1.0.6.6 manually as follows:

  1. Start PowerPoint
  2. Click the BrightSlide tab
  3. Click About
  4. Click License & Updates
  5. Hold the Shift key and click Check for Updates
  6. Follow the instructions
  7. When the update has finished, click the Theme Fonts button in BrightSlide to check that the error no longer occurs and that the fonts are listed as expected in alphabetical order:

 

text mistake typeface issue

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